Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 27, 2025 - 08:00 EST
Scheduled
In observance of the holiday, MSI will be closed on Thursday, 11/27/2025 and Friday, 11/28/2025.
Emergency Support will remain available during this time for an additional fee. Regular Business Support services will resume on Saturday, 11/29/2025 at 9:00 AM.
Please note: Bank holidays may impact the MeevoPay funding schedule, and the timing of deposits depends on your bank’s holiday operations:
• Payments received from clients between Wednesday, 11/26/2025 and Thursday, 11/27/2025 (where applicable) should be expected to deposit on Friday, 11/28/2025. Payments received Friday, 11/28/2025 and over the weekend will process as usual.
We recommend checking with your bank for specific holiday deposit timelines.
Posted Nov 24, 2025 - 12:07 EST
This scheduled maintenance affected: MeevoPay and Meevo Offices.