WorldPay: Some Transactions May Decline

Incident Report for Meevo

Resolved

Final update from WorldPay: Worldpay technical teams reverted a change to restore service. Worldpay will continue to monitor the environment for stability.
Posted Jun 26, 2025 - 06:52 EDT

Update

Update from WorldPay: Worldpay technical teams have identified an issue following a scheduled change. The change is scheduled to be reverted tonight during the scheduled maintenance window, and a final communication will be issued upon completion of the roll back.
Posted Jun 25, 2025 - 15:29 EDT

Identified

Our payment partner, Worldpay, is experiencing an issue that may cause some card transactions to be declined.

They’ve identified the cause and are working to resolve it. No ETA yet, but we’ll share updates as soon as we have them.

Thanks for your patience!
Posted Jun 25, 2025 - 11:37 EDT
This incident affected: Worldpay.