Payment Processing Outage

Incident Report for Meevo

Resolved

This has been resolved. Thank you again for your patience while we worked to resolve this!
Posted Feb 11, 2025 - 09:31 EST

Investigating

We are currently experiencing an outage with payment processing. We apologize for any inconvenience and thank you for your patience while we work to resolve this.
Posted Feb 11, 2025 - 08:45 EST
This incident affected: Worldpay, MeevoPay, and CardConnect.