MeevoPay: Possible Funding Delay

Incident Report for Meevo

Resolved

Funding has been released, and funds will be received today. We apologize for the delay and appreciate your understanding!
Posted Jul 02, 2025 - 13:56 EDT

Identified

We have identified the root issue and expect funds to be disbursed today. We will share updates as they become available.
Posted Jul 02, 2025 - 11:57 EDT

Investigating

We are currently investigating a potential delay in MeevoPay fund disbursements originally expected today, Wednesday July 2nd, for transactions from Tuesday July 1st. Our team is actively gathering information and working to process funds as quickly as possible. We will provide updates as soon as they become available. We apologize for any inconvenience and appreciate your patience.
Posted Jul 02, 2025 - 10:23 EDT
This incident affected: MeevoPay.