MeevoPay Self Boarding Applications Issue
Incident Report for Meevo
Resolved
This incident has been resolved.
Posted Nov 20, 2023 - 08:01 EST
Identified
An issue that prevents new MeevoPay Applications from being started has been identified. Resources are currently developing a solution as a priority, and there is no action needed at this time. If you need to start a MeevoPay Application immediately, please contact us directly at (973) 402-9500 and select Option 5 for MeevoPay Merchant Services. More updates to come as progress is made.

We thank you for your patience.
Posted Nov 16, 2023 - 11:21 EST
This incident affected: MeevoPay.