Textel Meevo Messenger Error

Incident Report for Meevo

Resolved

Textel has confirmed that this issue has been resolved. We are seeing messaging return to normal in Meevo Messenger. Thank you for your patience!
Posted Feb 04, 2026 - 12:05 EST

Investigating

We are receiving reports of a "Forbidden Status 403" error when attempting to message in Meevo Messenger using Textel. We are investigating the root cause and will update when we have identified the issue.
Posted Feb 04, 2026 - 11:35 EST
This incident affected: Meevo Integrations (Textel).