MeevoPay - Hosted Page Limited Use
Incident Report for Meevo
Resolved
This incident has been resolved.
Posted Mar 21, 2024 - 09:02 EDT
Monitoring
Adyen's engineering teams remain engaged on this issue and working through the failed tokens.

It has been reported that the majority of immediate impact has been mitigated, however, payments using impacted tokens generated during the outage time frame might still end in errors. To resolve this, an internal process is being developed to restore tokens created during the affected window.

An update will follow when the impacted tokens have been restored and the issue fully resolved.
Posted Mar 19, 2024 - 09:16 EDT
Identified
An issue has been identified by Adyen impacting MeevoPay features that leverage Hosted Page like: Self Pay, Cards on File and Online Booking Deposits. Transactions may be refused through those methods, standard card-present transactions through a credit card terminal are working as intended. A fix is currently being worked on to resolve the above issue.

No actions need to be taken at this time, we thank you for your patience.
Posted Mar 18, 2024 - 14:51 EDT
This incident affected: MeevoPay.