11/8 MeevoPay Funding Delays
Incident Report for Meevo
Resolved
All businesses should have received their deposits on Monday, 11/13. There was a cutoff on the funding, so you may have received two deposits split for the day (11/8). If you have any questions, concerns, or need help reconciling those deposits, please speak with our MeevoPay Merchant Services team at 973-402-8801 > option 5 for Merchant Services > option 3 for Billing, Statements, and Deposits.
Posted Nov 14, 2023 - 08:45 EST
Identified
We are aware of an error in MeevoPay funding for today, November 9th, 2023.

The impact was a delay in funding for card volume processed on Wednesday, November 8th, 2023.

We are aware that you did not receive your deposit as expected and apologize for any inconvenience this may have caused. You should expect to receive the issued funds tomorrow, November 10th, 2023.

If you have any questions, please contact us directly at (973) 402-8801 or MeevoPay@meevo.com. Thank you for your patience and understanding.
Posted Nov 09, 2023 - 12:30 EST
This incident affected: MeevoPay.