Worldpay - Outage
Incident Report for Meevo
Resolved
Worldpay technical resources resolved an internal error to restore service. Worldpay will continue to monitor the environment for stability.
Posted Dec 29, 2024 - 12:15 EST
Update
There is an incident affecting transaction authorizations on the Integrated Payments Express & MercuryPay platforms. Worldpay technical resources continue to work to identify and resolve the issue
Posted Dec 29, 2024 - 11:49 EST
Investigating
We are currently investigating an issue processing via WorldPay
Posted Dec 29, 2024 - 10:50 EST
This incident affected: Worldpay.