MeevoPay: Slight Funding Delay

Incident Report for Meevo

Resolved

This incident has been resolved.
Posted Mar 11, 2025 - 16:07 EDT

Monitoring

MeevoPay deposits are being processed, and while some may arrive slightly later than usual, all funds are still expected to be sent out today. We appreciate your patience and will continue to monitor the situation.
Posted Mar 11, 2025 - 11:10 EDT

Investigating

We are currently investigating a potential delay in MeevoPay fund disbursements originally expected today, Tuesday, March 11, for transactions from Monday, March 10. Our team is actively gathering information and working to process funds as quickly as possible. We will provide updates as soon as they become available. We apologize for any inconvenience and appreciate your patience.
Posted Mar 11, 2025 - 09:25 EDT
This incident affected: MeevoPay.