REACH - Duplicate Notification

Incident Report for Meevo

Resolved

This incident has been resolved.
Posted 1 year ago. Nov 21, 2023 - 17:06 EST

Monitoring

We have been notified that a fix has been implemented! For any other outstanding issues, please feel free to contact our Support team at (973) 402-8801.
Posted 1 year ago. Nov 21, 2023 - 16:02 EST

Identified

We have been made aware that some businesses using our partner REACH are encountering duplicate notifications being sent to their clients. We are working with REACH resources directly to resolve this issue, and will update when more information is provided.

Thank you for your patience!
Posted 1 year ago. Nov 21, 2023 - 15:55 EST