MeevoPay Funding Delay

Incident Report for Meevo

Resolved

A technical issue with our payment processors was identified this morning and the issue is now resolved, deposits should be received by end of day today. We apologize for any inconvenience this may have caused. Please reach out to Merchant Services at 973-402-8801 opt 5 if you do not receive funds by end of business day today.
Posted Nov 03, 2025 - 16:48 EST

Monitoring

A technical issue with our payment processors was identified this morning and the issue is now resolved, but some deposits were scheduled to settle today may take a bit longer than expected to process. We apologize for any inconvenience this may have caused. Please reach out to Merchant Services at 973-402-8801 opt 5 if you do not receive funds by end of business day today.
Posted Nov 03, 2025 - 09:55 EST
This incident affected: MeevoPay.