Microsoft Outage: Login, Online Booking, etc.
Incident Report for Meevo
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 18:17 EDT
Update
All features should be operational at this time.
Posted Jul 19, 2024 - 10:00 EDT
Update
Update: Some businesses are unable to load Online Booking still. We are working to get this up and running.
Posted Jul 19, 2024 - 07:53 EDT
Monitoring
Update: At this time, your access to Meevo should be restored and should remain stable, but you may have issues accessing your computers. We will continue to monitor the situation and provide updates as they're available.
Posted Jul 19, 2024 - 07:00 EDT
Identified
We are aware that some businesses are unable to access Meevo this morning. Please be aware that there is a global Microsoft outage which is impacting our Meevo servers and our employees' computer access. We are doing what we can to mitigate impact to our clients and will communicate as updates are available. We apologize for the impact and delays contacting our teams.
Posted Jul 19, 2024 - 02:00 EDT
This incident affected: CA0 Server Cluster (CA0 Server Performance and Access), NA0 Server Cluster (NA0 Server Performance and Access), NA1 Server Cluster (NA1 Server Performance and Access), UK0 Server Cluster (UK0 Server Performance and Access), NA2 Server Cluster (NA2 Server Performance and Access), and Meevo Offices.