Microsoft Outage: Login, Online Booking, etc.
Incident Report for Meevo
Resolved
This incident has been resolved.
Posted Jul 20, 2024 - 08:53 EDT
Monitoring
Continuation of Previous Incident. Some businesses continue to have issues logging in or other errors throughout Meevo. We are doing our best to mitigate these issues.

Original: We are aware that some businesses are unable to access Meevo this morning. Please be aware that there is a global Microsoft outage which is impacting our Meevo servers and our employees' computer access. We are doing what we can to mitigate impact to our clients and will communicate as updates are available. We apologize for the impact and delays contacting our teams.
Posted Jul 19, 2024 - 18:29 EDT
This incident affected: NA0 Server Cluster (NA0 Server Performance and Access) and NA1 Server Cluster (NA1 Server Performance and Access).