MeevoPay - Unable to add AMEX Cards on File
Incident Report for Meevo
Resolved
This incident has been resolved.
Posted Apr 29, 2024 - 16:07 EDT
Investigating
We are aware that some MeevoPay users are currently unable to add American Express cards to client accounts. We do not have a workaround at this time, but our teams are investigating to determine next steps and timeline. For security reasons, we do not recommend writing down credit card information. Any updates will be posted here.
Posted Apr 29, 2024 - 12:02 EDT
This incident affected: MeevoPay.