AMS1 - Tip not Prompting after software update

Incident Report for Meevo

Identified

The impacted AMS1 terminals will be rolled back to the previous version tonight. Please keep your devices powered on and connected to internet overnight.

To fix them on demand, you can go to Settings > Device Info > Software Version, and the previous software version (1.114.9) will be available for download.
Posted Apr 02, 2025 - 12:02 EDT

Investigating

There is a known issue affecting AMS1 terminals. The most recent software update (version 1.115.5) is causing these devices to bypass the tip prompt which usually shows during checkout.
In the meantime, you are able to manually apply the tips within the Register in Meevo. Select "Pay now," and the terminal will prompt for payment, including all line items as well as the tip combined. We appreciate your patience as we continue our investigation.
Posted Apr 01, 2025 - 15:12 EDT
This incident affects: MeevoPay.