UK0/CA0/NA2 Unhandled Errors are Being Received in the Appointment Book

Incident Report for Meevo

Resolved

This incident has been resolved. Our development team released a fix and can confirm the errors are no longer occurring when attempting to book, edit, cancel or move an appointment. Please reach out to support via 973-402-8801 option 2, live chat or email, if you have any further questions,
Posted Aug 12, 2025 - 16:37 EDT

Identified

Our team has identified an issue that may cause unhandled errors when adding, editing, moving, or deleting appointments. Our development team is actively working to resolve it as a top priority.

We apologize for any disruptions this may cause and appreciate your patience while we work to restore full functionality.
Posted Aug 12, 2025 - 10:41 EDT
This incident affected: CA0 Server Cluster (CA0 Server Performance and Access), UK0 Server Cluster (UK0 Server Performance and Access), and NA2 Server Cluster (NA2 Server Performance and Access).