Meevo Offices: Phone Outage
Incident Report for Meevo
Resolved
All teams should be coming back online for phone calls. We apologize for the inconvenience and are here to help!
Posted Dec 03, 2024 - 16:31 EST
Investigating
We are currently experiencing technical difficulties with our phone system and are unable to accept inbound calls. You can reach us via live chat or by emailing support@millenniumsi.com, and we will assist as soon as possible. We apologize for the inconvenience and will communicate any updates as soon as possible.
Posted Dec 03, 2024 - 15:58 EST
This incident affected: Meevo Offices.