eGift Suspicious Activity: CardConnect Subset
Incident Report for Meevo
Resolved
The eGift issue has been resolved and all eGift accounts have been reenabled.

Last week, we identified a security measure that helps prevent fraudulent eGift purchases and keeps credit card information safe was missing from the Meevo integration with CardConnect. As a precautionary measure, we temporarily deactivated eGift accounts for businesses using CardConnect.

The security issue has been addressed and all eGift accounts have been reactivated.

Thank you for your understanding. The security of your and your clients’ information is of the utmost importance to us at Meevo. Please feel free to contact your Client Success Manager if you have any questions.
Posted Jul 15, 2024 - 13:00 EDT
Update
Update: We are working closely with CardConnect to develop enhanced security protocols that would allow us to reactivate eGift for impacted businesses. At this time, we're hoping to be able to reactivate eGift early next week.
Posted Jul 11, 2024 - 10:13 EDT
Identified
The following incident impacts a small subset of CardConnect businesses utilizing eGift.

We recently identified suspicious behavior with eGift for clients using CardConnect.

As a result, we have proactively disabled your eGift account to prevent any fraudulent activity from occurring. As a security measure, we also recommend that you log into your CardConnect Account to change your password at your earliest convenience.

We will share further updates with you as they become available.
Posted Jul 08, 2024 - 17:55 EDT
This incident affected: eGift and CardConnect.