MeevoPay - Partial Payout delay for USD Payouts on October 15, 2024
Incident Report for Meevo
Resolved
This incident has been resolved.
Posted Oct 15, 2024 - 18:32 EDT
Identified
Due to a technical issue which is now resolved, a subset of customers will experience a delay in their United States Dollar (USD) payouts of up to 3.5 hours, scheduled to be received on October 15, 2024 at 13:30 ET (19:30 CEST). As the issue has been already resolved, the affected customers can expect to receive the funds in their accounts today, October 15, 2024 by 17:00 ET (23:00 CEST). We will continue monitoring and provide additional updates through system messages if required.
Posted Oct 15, 2024 - 14:50 EDT
This incident affected: MeevoPay.