Phone System Down

Incident Report for Meevo

Resolved

This incident has been resolved.
Posted Aug 06, 2025 - 08:09 EDT

Monitoring

A fix has been implemented, and initial testing is showing positive results. We’ve now moved into the monitoring phase to ensure stability.
Posted Aug 05, 2025 - 18:44 EDT

Identified

Our phone partner has identified the issue and is working towards a fix. We appreciate your patience and we'll update once more when fully resolved.
Posted Aug 05, 2025 - 16:18 EDT

Investigating

Our IT team is investigating an intermittent issue with our phone software, calls are not currently able to be completed at this time. We appreciate your patience while we work to get this resolved. If you need to contact support you can utilize live chat, Facebook, as well email via support@millenniumsi.com.
Posted Aug 05, 2025 - 12:11 EDT
This incident affected: Meevo Offices.