MeevoPay Deposit Delays Notice
Incident Report for Meevo
Resolved
We have identified the root cause of the issue and have implemented a fix. Thank you for your patience throughout this process. We are pleased to confirm that the issue has been resolved. Deposits from January 14, 2025, have been released and will be visible in your account on January 16, 2025.
Posted Jan 15, 2025 - 20:33 EST
Investigating
We are currently experiencing delays with MeevoPay deposits. Our Merchant Services team is actively investigating the issue and will provide updates as more information becomes available.
Posted Jan 15, 2025 - 14:17 EST
This incident affected: MeevoPay.